在 After Effects 中管理颜色 - After Effects 用户指南

返回介绍

在 After Effects 中管理颜色

发布于 2019-06-14 字数 25735 浏览 828 评论 0

After Effects 颜色管理视频介绍了颜色管理,其中对颜色管理的工作原理以及用法进行了说明。

色彩管理和颜色配置文件

色彩管理概述

颜色信息是通过数字进行传递的。因为不同的设备使用不同的方法来记录并显示颜色,所以相同的数字可能会有不同的解释并且向我们显示为不同的颜色。色彩管理系统跟踪所有这些解释颜色的不同方法并在它们之间进行转换,以便图像看起来是相同的,而不管用于显示它们的设备如何。

通常,颜色配置文件根据将特定于设备的色彩空间的颜色信息转换为与设备无关的色彩空间所需的变换,来介绍特定于设备的色彩空间。

在 After Effects 中的特定工作案例中,ICC 颜色配置文件用于在以下常规工作流中转换为工作色彩空间以及从工作色彩空间转换:

  1. 输入颜色配置文件用于将其色彩空间中的每个素材项目转换为工作色彩空间。素材项目可能包含嵌入的输入颜色配置文件,您也可以在“解释素材”对话框或解释规则文件中指定输入颜色配置文件。(请参阅通过分配输入颜色配置文件来解释素材项目。)
  2. After Effects 在工作色彩空间中执行其所有颜色操作。可在“项目设置”对话框中指定工作色彩空间(项目工作空间)。(请参阅选择有效色彩空间并启用色彩管理。)
  3. 通过显示器配置文件将颜色从工作色彩空间转换到您的计算机显示器的色彩空间。如果正确配置了两台不同的显示器,则此转换将确保您的合成在这两个不同的显示器上看起来相同。此转换不更改合成中的数据。您可以使用“视图”>“使用显示色彩管理”菜单命令来选择是否为您的显示器转换颜色。(请参阅启用或禁用显示色彩管理。)
  4. After Effects 可以选择使用模拟配置文件来在您的计算机显示器上向您演示合成将如何在不同设备上显示其最终输出形式。可通过“视图”>“模拟输出”菜单来控制每种视图的输出模拟。(请参阅模拟颜色在不同输出设备上的显示方式。)
  5. 每个输出模块的输出颜色配置文件用于将已渲染的合成从工作色彩空间转换到输出媒体的色彩空间。可在“输出模块设置”对话框中选择输出颜色配置文件。(请参阅分配输出颜色配置文件。)

默认情况下,在您使用色彩管理时,After Effects 会自动调整颜色以补偿场景引用的颜色配置文件和输出引用的颜色配置文件之间的灰度系数差异。(请参阅灰度系数和色调反应。)

注意:色彩管理的替代方法是使用颜色查询表 (LUT) 手动应用颜色变换。(请参阅应用 Color LUT 效果。)

色彩管理的优点

色彩管理具有许多优点,其中包括:

  • 所导入图像中的颜色按图像的创建者的预期显示。
  • 您可以针对从运动模糊到消除锯齿的所有内容,加强控制您的项目中的颜色混合方式。
  • 当在您的计算机显示器之外的设备上观看时,您创建的影片将按您的预期显示。

如果您没有为项目启用色彩管理,则您的合成中的颜色将取决于您的显示器的颜色特性:您看到的颜色是您的显示器基于您的素材项目中的 RGB 数值显示的颜色。因为不同的色彩空间使用相同的 RGB 数值来表示不同的颜色,所以您看到并合成的颜色可能不是素材创建者预期显示的颜色。事实上,这些颜色可能与预期颜色相差很远。

通过为项目设置工作色彩空间(将启用色彩管理),您可以执行两项操作:

  • 为合成及其他颜色操作定义共同的色彩空间。
  • 控制合成中颜色的外观。

如果素材项目具有嵌入的颜色配置文件(例如,素材项目是 Photoshop PSD 文件),则创建图像的人员所预期的颜色可以在您的合成中准确重现。该颜色配置文件包含确定如何将图像文件中的 RGB 数值转换为与设备无关的色彩空间的信息;显示器的颜色配置文件随后可用于确定您的显示器的色彩空间中的哪些 RGB 数值表示素材项目的预期颜色。在您从许多不同的源导入包含许多不同颜色配置文件的素材项目时,此自动转换变得更加重要。

颜色转换过程无需您执行任何操作。颜色清楚地显示在您的显示器上,就像创建图像时显示颜色一样。与您为工作空间选择的色彩空间相比,您的显示器可能具有有限的色域,并且在显示器上显示时,可能会剪切颜色。不过,您的项目中仍具有完整范围的颜色数据,并且不会在内部剪切颜色。

在您准备输出合成时,可以使用色彩管理将您的颜色转变为适合您的输出媒体的空间。在此阶段中,可按颜色的预期外观保存颜色的外观。

颜色配置文件

颜色配置文件的文件格式由 ICC(国际色彩联盟)进行标准化,并且包含它们的文件通常以 .icc 文件扩展名结尾。After Effects 附带了常用(和一些不常用)输入和输出类型的色彩空间的大量颜色配置文件。

After Effects 从多个位置加载颜色配置文件,这些位置包括:

  • Mac OS:Library/ColorSync/Profiles
  • Mac OS:Library/Application Support/Adobe/Color/Profiles
  • Windows:WINDOWS\system32\spool\drivers\color
  • Windows:Program Files\Common Files\Adobe\Color\Profiles

注意:您可以使用 Adobe Photoshop 创建自定义 ICC 配置文件。在 Photoshop 中,选择“编辑”>“颜色设置”。Photoshop“颜色设置”对话框的“工作空间”区域中的“RGB”和“CMYK”菜单包括用于保存和加载 ICC 配置文件和定义自定义配置文件的选项。

项目中使用的所有颜色配置文件保存在该项目中,因此您无需手动将颜色配置文件从一个系统传递到另一个系统,以在其他系统上打开项目。

注意:NTSC (1953) 颜色配置文件对应于过时的电视设备,因此不应使用。对于标清 NTSC 电视,请使用 SDTV NTSC 颜色配置文件之一。

在为输入、输出或模拟选择配置文件时,电影胶片配置文件不会显示,除非您的素材是 Cineon 素材,或者您选择了“显示所有可用配置文件”。如果您的素材是 Cineon 素材,将仅显示电影胶片配置文件,除非您选择了“显示所有可用配置文件”。

色彩管理提示

确保阅读“解释素材”、“项目设置”和“输出模块设置”对话框中的帮助文本。此文本可帮助您了解将在您解释素材、合成并输出渲染影片时完成的颜色转换。

确保您的工作环境提供一致的光照级别和色温。例如,太阳光的颜色特性整天都在变化,这会改变颜色在屏幕上的显示方式,因此,应始终拉上窗帘或在无窗户的房间中工作。

有关色彩管理的在线资源

Trish 和 Chris Meyer 在 Artbeats 网站上的相关文章中简要介绍了色彩管理。

Johan Steen 在他的网站上提供了详细的文章来解释 After Effects 中的色彩管理。该文章还介绍如何校准和配置显示器,如何在 Photoshop 中使用色彩管理,以及如何使用线性色彩空间。

有关颜色配置文件的信息,请参阅国际色彩联盟网站。

校准显示器并创建显示器的配置文件

在您校准显示器时,配置文件生成实用工具允许您保存描述显示器的颜色行为的颜色配置文件。此配置文件包含有关哪些颜色可以在显示器上重现,以及必须如何转换图像中的颜色值才能准确显示颜色的信息。After Effects 和您的操作系统可以使用这些信息来确保您在显示器上看到的颜色与您创建的输出影片中的颜色类似。

注意:显示器的性能随着时间推移而下降,每隔一个月左右需重新校准显示器并创建显示器的配置文件。如果发现很难或不可能将显示器校准到标准值,说明显示器可能太旧并且已偏色。

  1. 确保您的显示器已打开至少半小时,从而为它提供足够的时间来准备并生成更一致的输出。
  2. 确保您的显示器能够显示数百万种(24 位/像素)或更多颜色。
  3. 如果您没有使用硬件测量设备的配置文件生成软件,请删除您的显示器桌面上的彩色背景图案,并将桌面设置为显示中性灰色。文档周围纷乱或明亮的图案会干扰准确的颜色感觉。
  4. 请执行以下任一操作,校准显示器并创建显示器的配置文件:
    • 要获得最佳结果,请使用第三方软件和测量设备。通常,使用测量设备(如色度计)以及软件可以创建更准确的配置文件,因为工具所测得的显示器上显示的颜色要远比人眼准确。

      多数配置文件生成软件会自动将新的配置文件指定为默认显示器配置文件。有关如何手动指定显示器配置文件的说明,请参阅您的操作系统的文档。

    • 在 Mac OS 中,请使用位于“系统首选项”>“显示”>“颜色”选项卡中的“校准”实用工具。

选择工作色彩空间和启用色彩管理

通过在“项目设置”对话框中为项目选择工作色彩空间(工作空间),可为项目启用色彩管理。可使用“解释素材”对话框或解释规则文件控制对每个素材项目的色彩管理。可在“输出模块设置”对话框中控制对每个输出项的色彩管理。

如果在“项目设置”对话框中将“工作空间”设置为“无”,将对项目禁用色彩管理。

选择工作色彩空间是管理项目中颜色的一个重要步骤。素材项目的颜色将转换为工作色彩空间,并作为合成的常用色彩空间。

为获得最佳结果,请在使用 8-bpc 颜色时,使工作色彩空间与输出色彩空间相匹配。如果您要渲染到多个输出色彩空间,则应该至少将项目颜色深度设置为 16 bpc 或 32 bpc,以对最终输出进行渲染。工作色彩空间应该与具有最大色域的输出色彩空间匹配。例如,如果您计划输出到 Adobe RGB 和 sRGB,应使用 Adobe RGB 作为您的工作色彩空间,因为 Adobe RGB 具有更大的色域,因此可以表示更多的饱和色。要保留超过范围的值,请使用 32-bpc 颜色,因其动态范围很高。

有关工作色彩空间选择的建议:

  • 如果您要为标清广播电视(包括标清 DVD)制作影片,最好选择 SDTV NTSC 或 SDTV PAL。
  • 如果您要为高清电视制作影片,最好选择 HDTV (Rec. 709)。此色彩空间使用与 sRGB 相同的基色,但它具有更大的色域,因此它成为多种工作的合适工作空间。
  • 具有线性色调响应曲线(灰度系数为 1.0)的 ProPhoto RGB 是完成数字电影工作的最佳选择。
  • 如果要为 Web(特别是卡通)制作影片,最好选择 sRGB IEC61966-2.1。

After Effects 中提供的色彩空间因安装在您的计算机上的颜色配置文件而异。(请参阅颜色配置文件。)

  1. 选择“文件”>“项目设置”。
  2. 从“工作空间”菜单中选择工作色彩空间。

颜色管理和 Mercury Transmit

发送给视频显示器的颜色值来自项目的工作色彩空间。要预览视频颜色,请在“项目设置”对话框中选择与预览设备的色彩空间匹配的工作空间值。

使用 Mercury Transmit 发送到外部监视器的视频预览受到颜色管理。请参阅在外部视频监视器上预览部分了解详细信息。

注意:要管理动态链接的合成中的颜色或用于视频预览的颜色,请创建一个新合成并将您的合成嵌套在其中;然后对嵌套合成应用“颜色配置文件转换器”效果,并且将“输入配置文件”设置为“项目工作空间”。要预览视频,可将“输出配置文件”设置为与视频预览设备的色彩空间匹配。(请参阅“颜色配置文件转换器”效果。)

颜色管理和 Dynamic Link

如果为 After Effects 项目启用了颜色管理,通过 Dynamic Link 查看的合成将使用 Rec. 709 颜色配置文件进行转换。这可以防止这些合成在 Premiere Pro 和 Adobe Media Encoder 中显示时出现颜色或灰度偏移。

Dynamic Link 始终假设所有输入帧都采用 Rec. 709。颜色变换应用到合成上,这是图像传送到 Dynamic Link 供 Premiere Pro 或 Adobe Media Encoder 使用之前的最后一个步骤。这样可将合成图像校正为 Dynamic Link 所使用的色彩空间,其作用类似于使用 After Effects 中的“查看”>“启用显示颜色管理”选项校正监视器的图像。

将颜色配置文件导出到 Adobe Media Encoder

Adobe Media Encoder 将颜色配置文件嵌入从 After Effects 合成渲染的 JPEG 文件中。

要嵌入颜色配置文件,请执行以下步骤:

 

  1. 通过在“项目设置”中指定颜色工作空间配置文件,启用色彩管理。要打开“项目设置”,请选择“编辑”>“项目设置”。
  2. 在“项目设置”对话框中,单击“工作空间”并从下拉列表中选择颜色工作空间。

    在 After Effects 中管理颜色选择颜色工作空间

  3. 指定颜色工作空间后,将您的合成添加到渲染队列。要添加合成,请选择“文件”>“导出”>“添加到渲染队列”。

    在 After Effects 中管理颜色添加到渲染队列

  4. 在“渲染队列”面板中,单击“输出模块设置”。
  5. 在“输出模块设置”对话框中,单击“主要选项”并将格式更改为 JPEG。

    在 After Effects 中管理颜色将格式更改为 JPEG

  6. 设置格式后,单击“色彩管理”,选择“输出配置文件”并启用“嵌入配置文件”选项。

    在 After Effects 中管理颜色嵌入颜色配置文件

  7. 在“渲染队列”面板中,单击“在 AME 中排入队列”按钮。
  8. 此时合成在 Adobe Media Encoder 中启动。在 Adobe Media Encoder 中,将输出格式设置为 JPEG。

    在 After Effects 中管理颜色将输出格式设置为 JPEG

注意:如果未启用“嵌入配置文件”选项,Adobe Media Encoder 会嵌入 HDTV (Rec. 709) 配置文件。

线性化工作空间和启用线性混合

如果您启用了色彩管理(通过指定工作色彩空间),则可以通过线性化工作色彩空间在线性光中执行所有颜色操作。线性化色彩空间使用与非线性版本相同的基色和白场;线性化色彩空间的色调响应曲线只是一条直线。(请参阅灰度系数和色调反应。)

如果您没有启用色彩管理,则仍可以使用灰度系数 1.0 执行混合操作。

通过在线性色彩空间中执行操作,您可以防止某些边缘和光晕伪像,例如在将高对比度的饱和色混合在一起时出现的毛边。可在线性色彩空间中完成许多颜色操作,包括图像重新采样、采用混合模式的图层之间的混合、运动模糊和消除锯齿所涉及的那些操作。

如果您要使用线性化工作色彩空间,请在设置项目,而不是稍后切换时使用它。否则,在您切换到线性工作色彩空间时,在拾色器中选择的颜色将更改,因为 After Effects 中的颜色将解释为位于工作色彩空间中。

注意:线性化工作色彩空间与较高的颜色深度(16 bpc 和 32 bpc)结合使用时可发挥最大作用,并且不建议将其用于 8-bpc 颜色。

  1. 选择“文件”>“项目设置”,并执行下列操作之一:
    • 要线性化工作色彩空间,请选择“线性化工作空间”。
    • 要在线性色彩空间中混合颜色,请选择“使用 1.0 灰度系数混合颜色”。此选项仅影响图层之间的混合。结果是不透明度淡化、运动模糊和依赖混合模式的其他功能受到影响。

有关线性色彩空间和线性混合的其他资源

Stu Maschwitz 的 ProLost 博客中包含几篇有助于了解如何、何时以及为什么使用线性色彩空间,而不使用非线性色彩空间的文章。在此文章中,Stu 概述了有关使用线性色彩空间和线性混合的原因和技术。

通过指定输入颜色配置文件来解释素材项目

您可以使用“解释素材”对话框来控制对每个素材项目的色彩管理。

输入颜色配置文件确定在将素材项目的颜色转换为项目的工作色彩空间时执行哪些计算。如果尚未设置工作空间,那么如果没有对项目启用色彩管理,则您无法指定输入颜色配置文件。

在某些情况下,您导入的文件中已嵌入 ICC 配置文件。在导入这些文件时,您可以确信您看到的颜色正是素材的制作人最初所预期的。After Effects 可以读取并写入 Photoshop (PSD)、TIFF、PNG 和 JPEG 文件的嵌入颜色配置文件。

如果素材项目没有嵌入的颜色配置文件,则您可以使用“解释素材”对话框或通过在解释规则文件 (interpretation rules.txt) 中添加或修改规则来指定输入颜色配置文件。After Effects 将解释此素材项目,就好像源素材是使用此颜色配置文件创建的一样,因此一定要指定与用于创建源素材的配置文件匹配(或至少接近)的配置文件。

注意:如果源素材项目是由不使用色彩管理的应用程序创建的(例如从 3D 应用程序渲染的影片),则输入颜色配置文件实际上是在其上设计并创建图像的系统的显示器配置文件。

  1. 在“项目”面板中选择素材项目。
  2. 选择“文件”>“解释素材”>“主要”。
  3. 在“解释素材”对话框的“色彩管理”选项卡中,从“指定配置文件”菜单中选择一个值。

    如果“指定配置文件”菜单中未显示所需的配置文件,请选择“显示所有可用配置文件”。

  4. 阅读对话框的“描述”区域中的信息,以确认转换是您所需的转换,然后单击“确定”。

无法为非 RGB 素材项目(例如 CMYK、Y’CbCr 和摄像机原始图像)指定输入配置文件。这些素材项目的原生色彩空间显示在“解释素材”对话框中。将自动为每种格式处理非 RGB 颜色值到 RGB 颜色值的转换。

如果您没有指定输入颜色配置文件,并且 After Effects 在解释规则文件中不具有用于解释的规则,则假定素材项目的颜色位于项目的工作色彩空间中。

在启用色彩管理时,素材项目的输入颜色配置文件显示在“项目”面板顶端的信息区域中。

“解释为线性光”选项确定是否将指定的输入颜色配置文件解释为线性(灰度系数等于 1.0)。在对项目禁用色彩管理时,也可使用此选项。(请参阅灰度系数和色调反应。)

通过选择“解释素材”对话框的“色彩管理”选项卡中的“保留 RGB”,您可以防止将颜色转换为单个素材项目的工作色彩空间。此选项保留 RGB 数值;不保留颜色外观。如果不打算将某特定素材项目用于视觉显示,而是打算将其用作控制图层(例如,置换图),那么对该素材项目禁用色彩管理将很有用。

指定输出颜色配置文件

您可以使用“输出模块设置”对话框控制对每个输出项的色彩管理。  

注意:在导出为 SWF 格式时,可使用“导出”菜单,而不能使用“渲染队列”面板,因此输出模块设置不适用于此输出类型。如果对项目启用色彩管理,则在导出为 SWF 时,After Effects 会自动将颜色从项目的工作色彩空间转换为 sRGB IEC61966-2.1 色彩空间。

渲染项的输出颜色配置文件确定在将渲染合成的颜色从项目的工作色彩空间转换为输出媒体的色彩空间时执行哪些计算。如果尚未设置项目工作空间,那么如果没有对项目启用色彩管理,则您无法指定输出颜色配置文件。

例如,在 HDTV (Rec. 709) 工作色彩空间中创建要输出到胶片的影片后,您很可能希望使用胶片输出颜色配置文件输出到对数编码的 Cineon/DPX 色彩空间。另一方面,如果您要为高清电视创建影片,则应该选择 HDTV (Rec. 709) 输出配置文件。

渲染项的输出颜色配置文件是输出模块的一部分,并且显示在“渲染队列”面板中的输出模块组中。您可以将多个输出模块指定给一个渲染项,其中每个输出模块具有自己的输出颜色配置文件,从而允许您从一个渲染影片为各种媒体创建输出影片。

“转换为线性光”选项确定是否将颜色输出到线性颜色配置文件(灰度系数等于 1.0)。输出到线性光不太适合 8-bpc 或 16-bpc 颜色,因此“转换为线性光”的默认设置是“对 32 bpc 打开”。(请参阅灰度系数和色调反应。)

一些文件格式(例如 Photoshop (PSD)、PNG、TIFF 和 JPEG)允许嵌入颜色配置文件。如果您在输出文件中嵌入颜色配置文件,则可以更加确信使用该文件的程序将正确解释其颜色信息。

After Effects 根据您选择的输出颜色配置文件选择渲染意向。对于大多数输出类型,渲染意向是相对色度(具有黑场补偿);对于输出到负片,渲染意向是绝对色度。

通过选择“输出模块设置”对话框的“色彩管理”选项卡中的“保留 RGB”,您可以防止单个输出项的工作色彩空间的颜色转换。此选项保留 RGB 数值;不保留颜色外观。如果不打算将某特定素材项目用于视觉显示,而是打算将其用作控制图层(例如,置换图),那么对该素材项目禁用色彩管理将很有用。

  1. 单击“渲染队列”面板中渲染项的“输出模块”标题旁边带下划线的文本。
  2. 在“输出模块设置”对话框的“色彩管理”选项卡中,从“输出配置文件”菜单中选择一个值。

    如果“输出配置文件”菜单中未显示所需的配置文件,请选择“显示所有可用配置文件”。此选项显示电影胶片颜色配置文件。

  3. 阅读对话框的“描述”区域中的信息,以确认转换是您所需的转换,然后单击“确定”。

启用或禁用显示色彩管理

在启用色彩管理后,默认行为是将 RGB 像素值从项目的工作色彩空间转换为您的计算机显示器的色彩空间。将保留颜色外观;不保留 RGB 数值。此行为针对大多数使用情形,但您有时需要了解在通过不使用色彩管理的系统进行观看时颜色的实际外观。例如,您可能需要了解在 Web 浏览器中观看时颜色将如何显示。

在禁用显示色彩管理后,会将 RGB 颜色值直接发送到您的显示器,而不通过显示器配置文件进行任何转换。将保留 RGB 数值;不保留颜色外观。

在对查看器启用显示色彩管理后,查看器底部的“显示通道及色彩管理设置” 在 After Effects 中管理颜色 按钮上会出现一个黄色加号。

对于每个查看器(“合成”、“图层”或“素材”面板),您可以选择是否管理显示器颜色,这涉及将颜色从工作色彩空间转换为显示器的色彩空间。

  1. 激活“合成”、“图层”或“素材”面板。
  2. 执行下列操作之一来在启用和禁用显示色彩管理之间切换:
    • 单击查看器底部的“显示通道及色彩管理设置” 在 After Effects 中管理颜色 按钮,然后选择“使用显示色彩管理”。
    • 选择“视图”>“使用显示色彩管理”。
    • 按 Shift+/(在数字键盘上)。

将记住输出模拟设置(包括“无输出模拟”)。

模拟颜色在不同输出设备上的显示方式

通常,您需要预览影片在您的计算机显示器之外设备上的外观。色彩管理的一个目的是确保颜色在所有设备上显示一致,但 After Effects 中的色彩管理无法解决如下情况:

  • 您为其创建影片的输出设备具有比您的项目的工作色彩空间小的色域,因此该设备无法呈现一些颜色。
  • 您的影片中的颜色由不使用色彩管理转换颜色的设备或软件显示。

例如,在您使用计算机显示器和高清视频显示器创建影片时,您可能需要了解影片在传递到特定库存胶片并在标准剧院观看条件下投影时的外观。

在此类情况下,您将需要预览当颜色显示在您的计算机显示器之外的设备上时,这些颜色的外观。输出模拟需要显示色彩管理。

在输出模拟期间,颜色通过以下流程从项目的工作色彩空间转换为显示器的色彩空间:

1. 颜色从项目的工作色彩空间转换为输出色彩空间。

使用输出颜色配置文件(将用于渲染最终输出的相同配置文件)将颜色从工作色彩空间转换为输出类型的色彩空间。

2. 颜色从输出色彩空间转换为模拟播放设备的色彩空间。

如果未选择“保留 RGB”,则使用模拟配置文件将颜色从输出色彩空间转换为演示媒体的色彩空间。此设置假定模拟设备也执行色彩管理并将转换显示颜色。将保留颜色外观;不保留 RGB 数值。

如果选择“保留 RGB”,则在此步骤中不转换颜色值。相反,将保留数字 RGB 颜色值,并将其重新解释为位于模拟设备的色彩空间中。此模拟的一个用途是查看影片在预期设备之外的设备上或在不执行色彩管理的设备上播放时的外观。

注意:在模拟捕获库存胶片和打印库存胶片的组合时,将使用“保留 RGB”。

3. 颜色从模拟播放设备的色彩空间转换为您的显示器的色彩空间。

使用显示器配置文件将颜色从演示设备色彩空间转换为您的计算机显示器的色彩空间。

在您创建输出模拟预设时,可以选择要用于其中每个步骤的配置文件。

注意:即使您使用了预设输出模拟,也可以在选择预设之后选择“视图”>“模拟输出”菜单中的“自定义”选项来查看为该模拟类型执行的颜色转换和重新解释的表示形式。

输出模拟仅适用于特定查看器(“合成”、“图层”或“素材”面板)并仅用于预览。在将值发送给显示器时,执行输出模拟的颜色转换。项目中的实际颜色编号没有更改。

对于所有色彩空间转换,模拟输出会略微降低性能,因此您在执行需要实时交互的任务时可能不希望模拟输出。

注意:仅应用正确的配置文件无法补偿不同设备的不同色域。例如,个人计算机的常用 LCD 显示器不具有完全模拟 HDTV 输出所需的色域。

您可以按 Shift+/(在数字键盘上)来启用或禁用显示色彩管理。禁用显示色彩管理还会禁用输出模拟。在禁用显示色彩管理时,会记住模拟设置(包括“无输出模拟”)。

模拟预览输出

  1. 激活“合成”、“图层”或“素材”面板。
  2. 选择“视图”>“模拟输出”,然后选择要模拟的输出类型。

    注意:输出模拟依赖显示色彩管理,后者在默认情况下处于启用状态。如果禁用显示色彩管理,请选择“视图”>“使用显示色彩管理”。

    无输出模拟

    显示色彩管理已启用,但没有执行任何转换来模拟输出类型。

    旧版 Macintosh RGB(灰度系数 1.8)

    显示颜色在由灰度系数为 1.8(Mac OS X 10.6 之前的 Mac OS 使用的值)的 Macintosh 计算机上的非色彩管理应用程序显示时将如何呈现。如果选择了“线性化工作空间”,则此选项不可用。

    Internet 标准 RGB (sRGB)

    显示颜色在由灰度系数为 2.2 的非色彩管理应用程序显示时将如何呈现。如果选择了“线性化工作空间”,则此选项不可用。

    Kodak 5218 至 Kodak 2383

    显示颜色在输出到 Kodak 5218 库存负片,然后在剧院环境中从 Kodak 2383 库存正片投影时将如何呈现。

    注意:After Effects 7.0 提供的与“校样颜色”命令一起使用的 DPX Theater Preview 和 DPX Standard Camera 配置文件已由与“模拟输出”命令一起使用的 Kodak 2383 和 Kodak 5218 配置文件取代。

    自定义

    如果未显示要模拟的输出类型条目,可以通过选择“自定义”来创建自己的输出模拟预设。您可以指定要用于每个转换或重新解释步骤的配置文件。

    • 要预览在您将影片输出到设备并在该设备上进行观看时该影片的外观,请对输出配置文件和模拟配置文件使用相同的值。
    • 要预览在您将影片输出到一台设备,然后在另一台色彩管理设备上进行观看时该影片的外观,请对输出配置文件和模拟配置文件使用不同的值,并取消选择“保留 RGB”。
    • 要预览在您将影片输出到一台设备并在另一台设备上进行观看时该影片的外观,请对输出配置文件和模拟配置文件使用不同的值,并且选择“保留 RGB”。

您可以为每种视图选择输出模拟预设。在所有视图之间共享自定义输出模拟设置。

注意:要在无输出模拟和最近使用的输出模拟之间切换,请单击查看器底部的“显示通道及色彩管理设置” 在 After Effects 中管理颜色 按钮并选择“模拟输出”。

在为最终输出渲染的影片中模拟输出类型

输出模拟的色彩管理仅用于预览,但您可以使用模拟特定输出类型的外观渲染影片。例如,您可以渲染可模拟胶片放映的 HDTV 影片,这对在进行影片制作时创建样片尤其有用。

  1. 选择“图层”>“新建”>“调整图层”以在您的合成的顶端创建新调整图层。
  2. 选择“效果”>“实用工具”>“颜色配置文件转换器”,将颜色配置文件转换器应用于调整图层。
  3. 选择“编辑”>“复制”来复制效果。
  4. 在“效果控件”面板中,为效果的第一个实例设置以下选项:

    输入配置文件

    项目工作空间

    输出配置文件

    要模拟的输出类型;例如,胶片打印密度配置文件,如 Kodak 5218/7218 Printing Density

    意图

    绝对色度

  5. 在“效果控件”面板中,为效果的第二个实例设置以下选项:

    输入配置文件

    要模拟的播放类型;例如,剧院预览配置文件

    输出配置文件

    输出媒体的色彩空间;例如 HDTV (Rec.709)

    意图

    相对色度

要启用和禁用这种类型的输出模拟,您可以通过在“时间轴”面板中选择或取消选择其视频开关来启用或禁用调整图层。

广播安全颜色

模拟视频信号振幅以 IRE 单位(或 PAL 视频中的伏特数)表示。7.5 和 100 IRE 单位之间的值被认为是广播安全;此范围中的颜色不会产生不需要的伪像,例如音频噪声和颜色模糊。(在实践中,一些超过 100 IRE 的峰值是有效的,但为简单起见,此处将 100 IRE 视为最高有效值。)此 7.5-100 IRE 范围相当于 Y’CbCr 中 Y’ 的 10-bpc 值为 64-940 的从黑色到白色的范围,这与 8-bpc 值中的 16-235 相对应。因此,许多常见视频设备和软件系统将 16 解释为黑色,将 235 解释为白色,而不是 0 和 255。这些数字不直接与 RGB 值相对应。

如果您注意到所导入素材的颜色看起来是错误的(黑色看起来不够黑,白色看起来不够白),请确保您指定了正确的输入颜色配置文件。After Effects 附带的常用视频颜色配置文件包括说明这些有限范围的变体,例如 HDTV (Rec. 709) 16-235 颜色配置文件,它将 16 解释为黑色,将 235 解释为白色。

注意:一些视频卡和编码器假定输出范围为 0-255,因此在您的合成和渲染的影片中限制颜色可能是多余的,并导致不需要的颜色范围压缩。如果输出影片的颜色看起来昏暗,请尝试指定使用完整颜色范围的输出颜色配置文件。

注意:如果颜色看起来褪色,请应用“色阶”效果并查看直方图,以确认最低和最高颜色值是否为或接近 16 和 235。如果颜色值正确,则应使用 16-235 输入颜色配置文件之一解释此素材。

您可以使用“广播颜色”效果来将明亮度或饱和度减小到安全级别,但将输出颜色限制在广播安全范围内的最好方法是创建您的合成以不使用此范围之外的颜色。(请参阅“广播颜色”效果。)

记住下列原则:

  • 避免纯黑和纯白值。
  • 避免使用高度饱和的颜色。
  • 渲染测试影片,并在视频显示器上播放它以确保准确呈现颜色。

注意:无需使用“广播颜色”效果来减小颜色的明亮度或饱和度,您可以将此效果与“抠出不安全区域”或“抠出安全区域”选项结合使用。将此效果应用于图层堆栈顶端的调整图层,以指名图像的哪些部分在广播安全范围之外。

After Effects 附带的 Color Finesse 增效工具包括可帮助您使颜色始终位于广播安全范围内的丰富工具。有关详细信息,请参阅包含 Color Finesse 增效工具的文件夹中的 Color Finesse 文档。(请参阅颜色校正、颜色分级和颜色调整。)

注意:After Effects 7.0 在“解释素材”对话框中提供“扩展 ITU-R 601 明亮度级别”选项。在 After Effects CS3 或更高版本中打开时,将为使用此选项创建的项目中的素材项目指定相应的配置文件。

更多此类内容

  • 解释素材项目
  • 输出模块和输出模块设置
  • 颜色模型和色彩空间
  • 颜色深度和高动态范围颜色
  • 混合模式和图层样式
  • 解释素材项目
  • 输出模块和输出模块设置
  • 使用渲染队列渲染和导出影片
  • 查看器
  • 预览

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

目前还没有任何评论,快来抢沙发吧!