如何在 Animate CC 中使用 ActionScript - Adobe Animate 用户指南

返回介绍

如何在 Animate CC 中使用 ActionScript

发布于 2019-06-28 字数 14979 浏览 942 评论 0

ActionScript 快速入门

ActionScript® 脚本撰写语言允许您向应用程序添加复杂的交互性、播放控制和数据显示。可以使用动作面板、“脚本”窗口或外部编辑器在创作环境内添加 ActionScript。

ActionScript 遵循自身的语法规则和保留关键字,并且允许使用变量存储和检索信息。 ActionScript 含有一个很大的内置类库,使您可以通过创建对象来执行许多有用的任务。 有关 ActionScript 的详细信息,请参阅下列帮助标题:

  • 学习使用 ActionScript 3.0,网址 www.adobe.com/go/learn_flcs5_learnas3_cn
  • 学习在 Adobe Animate 中使用 ActionScript 2.0,网址 www.adobe.com/go/learn_cs5_learningas2_cn

您不需要了解每个 ActionScript 元素就可以开始编写脚本。如果您有一个明确的目标,则可以开始通过简单操作生成脚本。

ActionScript 和 JavaScript 均基于 ECMA-262 标准,后者是 ECMAScript 脚本撰写语言的国际标准。因此,熟悉 JavaScript 的开发人员很快就可以熟悉 ActionScript。有关 ECMAScript 的详细信息,请访问 ecma-international.org。

Adobe 推荐的资源…

Adobe 推荐的资源…

您可以使用哪个 ActionScript 版本?

Animate 包含多个 ActionScript 版本,以满足各类开发人员和播放硬件的需要。ActionScript 3.0 和 2.0 相互之间不兼容。

 

  • ActionScript 3.0 的执行速度很快。与其他 ActionScript 版本相比,此版本要求开发人员对面向对象的编程概念有更深入的了解。ActionScript 3.0 完全符合 ECMAScript 规范,提供了更出色的 XML 处理、一个改进的事件模型以及一个用于处理屏幕元素的改进的体系结构。 使用 ActionScript 3.0 的 FLA 文件不能包含 ActionScript 的早期版本。
  • (Animate CC 中已弃用)ActionScript 2.0 比 ActionScript 3.0 更容易学习。尽管 Flash Player 运行编译后的 ActionScript 2.0 代码比运行编译后的 ActionScript 3.0 代码的速度慢,但 ActionScript 2.0 对于许多类型的项目仍然十分有用。ActionScript 2.0 对于计算量不大的项目也非常有用。例如,更面向设计的内容。ActionScript 2.0 也基于 ECMAScript 规范,但并不完全遵循该规范。
  • (Animate CC 中已弃用)ActionScript 1.0 是最简单的 ActionScript,仍被 Adobe Flash Lite Player 的一些版本所使用。ActionScript 1.0 和 2.0 可以在同一 FLA 文件中同时存在。
  • (Animate CC 中已弃用)Flash Lite 2.x ActionScript 是 ActionScript 2.0 的子集,受移动电话和移动设备上的 Flash Lite 2.x 的支持。
  • (Animate CC 中已弃用)Flash Lite 1.x ActionScript 是 ActionScript 1.0 的子集,受移动电话和移动设备上的 Flash Lite 1.x 的支持。

 

使用 ActionScript 文档

由于有多个 ActionScript 版本(2.0 和 3.0),并且有多种将其合并到 FLA 文件中的方法,因此也有学习使用 ActionScript 的不同途径。

您可以找到有关使用 ActionScript 的图形用户界面的描述。此界面包含动作面板、“脚本”窗口、“脚本助手”模式、“行为”面板、输出面板和“编译器错误”面板。 这些主题适用于 ActionScript 的所有版本。

Adobe 的其他 ActionScript 文档可指导您了解 ActionScript 的各个版本。

ActionScript 的使用方法

有多种使用 ActionScript 的方法。

  • (Animate CC 中已弃用)使用“脚本助手”模式可以将 ActionScript 添加到 FLA 文件,而无需自行编写代码。您选择动作,然后软件将显示一个用户界面,用于输入每个动作所需的参数。对完成特定任务应使用哪些函数有所了解,但不必学习语法。许多设计人员和非程序员都使用此模式。
  • (Animate CC 中已弃用)使用行为也可以将代码添加到文件中,而无需自行编写代码。行为是针对常见任务预先编写的脚本。 可以添加行为,然后轻松地在“行为”面板中配置它。 行为仅对 ActionScript 2.0 及更早版本可用。
  • 编写自己的 ActionScript 可使您获得最大的灵活性和对文档的最大控制力。但是,同时要求您熟悉 ActionScript 语言和约定。
  • 组件是预先构建的影片剪辑,让您能够实现复杂的功能。组件可以是一个简单的用户界面控件(如复选框),也可以是一个复杂的控件(如滚动窗格)。 您可以自定义组件的功能和外观,并可下载其他开发人员创建的组件。 大多数组件要求您自行编写一些 ActionScript 代码来触发或控制组件。 有关更多信息,请参阅使用 ActionScript 3.0 组件。

 

编写 ActionScript

在创作环境中编写 ActionScript 代码时,可使用“动作”面板或“脚本”窗口。“动作”面板和“脚本”窗口包含功能完备的代码编辑器,其中包括代码提示和着色、代码格式设置和语法突出显示功能。它还包含调试、行号、自动换行以及对 Unicode 的支持。

  • 可使用“动作”面板来编写放在 Animate 文档中的脚本(即嵌入 FLA 文件中的脚本)。“动作”面板提供了一些功能(例如“动作”工具箱),让您能够快速访问核心 ActionScript 语言元素。您会收到创建脚本所需元素的提示。
  • 若要编写外部脚本(即存储在外部文件中的脚本或类),可以使用“脚本”窗口。 (也可以使用文本编辑器创建外部 AS 文件。) “脚本”窗口具有代码帮助功能,例如代码提示和着色、语法检查和自动套用格式。

更多推荐的社区内容

  • ActionScript 3.0 快速入门 (CS3) (3:25)
  • 优化动画和 FLA 文件 (7:24) (CS3)
  • 使用 ActionScript 3.0 创建文档类 (CS3) (2:38)
  • 创建衔接设计和开发的高效工作流程 (CS3) (3:41)
  • 使用组件 (CS3) (1:47)
  • YouTube.com 上 ActionScript 频道列表

下列文章和教程提供了有关使用 ActionScript 的更多详细信息:

  • ActionScript 3.0 简介 (Slekx.com)
  • ActionScript 3 迁移表 (Adobe.com)

输出面板概述

执行任一文档类型时,“输出”面板可显示与文档转换和发布等操作相关的信息或警告。若要显示此信息,请将 trace() 语句添加到代码中,或使用 List Objects(列出对象)和 List Variables(列出变量)命令。

如果在脚本中使用 trace() 语句,可以在 SWF 文件运行时向输出面板发送特定的信息。 其中包括 SWF 文件的状态说明或者表达式的值。 

如何在 Animate CC 中使用 ActionScript输出面板

输出面板包含以下菜单项:

  • 复制:将输出面板的全部内容复制到计算机的剪贴板。若要复制所选的输出部分,请选择需要复制的区域,然后选择“复制”。
  • 清除:清除输出面板的内容。
  • 显示输出:显示输出面板的内容。
  • 锁定:锁定面板。只能调整面板大小,不能移动或拖动面板。 
  • 帮助:加载输出面板的在线帮助。
  • 关闭:关闭输出面板。
  • 关闭组:关闭整个面板组。您可以同时将多个面板停靠在一起,例如时间轴、输出面板和编译器错误面板。

要显示或隐藏输出面板,请选择“窗口”>“输出”或按 F2。

动作面板

是否查找语言参考?

要查找特定 ActionScript 语言元素的参考文档,请执行下列操作之一:

  • 打开 ActionScript 3.0 语言参考,然后搜索语言元素。
  • (Animate CC 中已弃用)打开 《ActionScript 2.0 语言参考》,然后搜索语言元素。
  • 在“动作”面板上键入语言元素,选中它,然后按 F1(立即按 F1)。

注意:要在 Web 浏览器而不是社区帮助应用程序中打开“帮助”,请参阅此文章:http://kb2.adobe.com/community/publishing/916/cpsid_91609.html。

学习使用 ActionScript

若要了解如何编写 ActionScript 代码,请使用以下资源:

  • 学习使用 ActionScript 3.0
  • 《ActionScript 3.0 语言和组件参考》
  • 学习在 Adobe Animate 中使用 ActionScript 2.0
  • 《ActionScript 2.0 语言参考》

注意:ActionScript 3.0 和 2.0 彼此互不兼容。为您创建的每个 FLA 文件仅选择一个版本。

动作面板概述

要创建在 FLA 文件中嵌入的脚本,请将 ActionScript 直接输入到动作面板(“窗口”>“动作”或按 F9)。

如何在 Animate CC 中使用 ActionScript动作面板

动作面板包含两个窗格:

“脚本”窗格

让您键入与当前所选帧相关联的 ActionScript 代码。

脚本导航器

列出 Animate 文档中的脚本,您可以快速查看这些脚本。要在“脚本”窗格中查看该脚本,请单击“脚本”导航器中的项目。

使用动作面板可以访问代码帮助功能,这些功能可简化 ActionScript 中的编码工作。您可以添加并非特定于帧的全局和第三方脚本,这些脚本可以应用于 Animate 中的整个动画。有关更多信息,请参阅本页的添加全局第三方脚本部分。 

  • 运行脚本:运行脚本
  • 固定脚本:将脚本固定到脚本窗格中各个脚本的固定标签,然后相应移动它们。如果您没有将 FLA 文件中的代码组织到一个中央位置,则此功能非常有用。或者,如果您使用多个脚本,它也非常有用。您可以将脚本固定,以保留代码在动作面板中的打开位置,然后在各个打开的不同脚本中切换。本功能在调试时非常有用。
  • 插入实例路径和名称:帮助您设置脚本中某个动作的绝对或相对目标路径。
  • 查找:查找并替换脚本中的文本。
  • 设置代码格式:帮助设置代码格式。
  • 代码片段:打开“代码片段”面板,其中显示代码片段示例。
  • 使用向导添加:单击此按钮可使用简单易用的向导添加动作,而无需编写代码。
  • 帮助:显示“脚本”窗格中所选 ActionScript 元素的参考信息。例如,如果单击 import 语句,再单击“帮助”,“帮助”面板中将显示 import 的参考信息。

使用动作码向导

使用“动作”面板中的“使用向导添加”选项,您可以将交互功能添加到 HTML5 组件中。“使用向导添加”是一个简化的用户界面,用于向您的组合中添加代码。

一段描述如何使用动作代码向导添加代码的视频

  1. 创建一个 HTML5 Canvas 文档,然后单击“窗口”>“动作”。
  2. 按下面的截图中所示,在“动作”面板中单击“使用向导添加”。

    如何在 Animate CC 中使用 ActionScript具有“使用向导添加”按钮的动作面板

  3. 选择您要使用代码向导为其创建代码的动作。

    如何在 Animate CC 中使用 ActionScript显示动作的动作代码向导选项的示例屏幕快照

    在上面的截图中,已选择“获取帧编号”动作,并且相应的代码已在“动作”窗口中更新。

    根据您选择的动作类型,您还可以选择要对其应用该动作的相应对象。如果对象具有实例名称,您可以在舞台上搜索特定对象。您还可以对当前选定对象应用相应操作。 

    如何在 Animate CC 中使用 ActionScript要对其应用操作的对象的列表

  4. 单击“下一步”选择触发事件。根据您在前面步骤中选择的动作类型和对象类型,该窗口中列出了一组触发器事件。

    如何在 Animate CC 中使用 ActionScript触发事件列表

  5. 选择适当的触发器事件,然后选择其相应的触发对象(如果有),然后单击“完成并添加” 按钮。

当您在舞台上选择对象并运行动作码向导时,您可以从菜单中选择“当前选择” 选项。您还可以为代码选择时间轴和组件动作。

使用脚本窗口

使用“脚本”窗口可以创建要导入应用程序的外部脚本文件。这些脚本可以是 ActionScript 文件,也可以是 Animate JavaScript 文件。

还可以在 HTML5 Canvas 文档中添加全局和第三方脚本。有关详细信息,请参阅“在 Animate CC 中创建和发布 HTML5 Canvas 文档”中的添加全局和第三方脚本部分。

如何在 Animate CC 中使用 ActionScript“脚本”窗口

如果同时打开多个外部文件,文件名将显示在沿“脚本”窗口顶部排列的选项卡上。

在“脚本”窗口中,可以使用 PinScript、查找和替换、语法着色、代码格式设置、代码提示和注释以及代码折叠功能。您还可以使用调试选项(仅限 ActionScript 文件)和自动换行。使用“脚本”窗口还可以显示行号和隐藏字符。

在脚本窗口中创建外部文件

  1. 选择“文件”>“新建”。

    如何在 Animate CC 中使用 ActionScript新建文档

  2. 从屏幕顶部的选项卡(如“角色动画”、“社交”、“游戏”、“教育”、“广告”、“Web”和“高级”)中选择目标。选择要创建的外部文件类型(ActionScript 文件或 Animate JavaScript 文件)。

在脚本窗口中编辑现有文件

  • 要打开现有脚本,请选择“文件”>“打开”,然后打开现有 AS 文件。
  • 要编辑已打开的脚本,请单击显示该脚本名称的文档选项卡。

动作面板和脚本窗口中的工具

使用动作面板可以访问代码帮助功能,这些功能可简化 ActionScript 中的编码工作。

查找

查找并替换脚本中的文本。

 

插入目标路径

(仅限动作面板)帮助您为脚本中的某个动作设置绝对或相对目标路径。

 

帮助 

显示“脚本”窗格中所选 ActionScript 元素的参考信息。例如,如果单击 import 语句,然后单击“帮助”, “帮助”面板中将显示有关 import 的参考信息。

 

代码片段

打开“代码片段”面板,其中显示示例代码片段。

 

使用向导添加

帮助您无需编写代码就可以使用接口添加动作的代码。 

从“动作”面板访问区分上下文的帮助

  1. 要选择一个参考项,请执行以下操作之一:
    • 在“动作”面板的工具箱窗格(位于“动作”面板的左侧)中选择一个 ActionScript 术语。
    • 在“脚本”窗格的“动作”面板中选择一个 ActionScript 术语。
    • 在“动作”面板的“脚本”窗格中,将插入点置于一个 ActionScript 术语前。
  2. 要打开选定项的“帮助”面板参考页,请执行以下操作之一:
    • 按 F1。
    • 右键单击该项并选择“查看帮助”。
    • 单击“脚本”窗格上方的“帮助”如何在 Animate CC 中使用 ActionScript

设置 ActionScript 首选参数

无论是在动作面板还是在“脚本”窗口中编辑代码,都可以设置和修改一组首选参数。

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh),然后单击“类别”列表中的“代码编辑器”。
  2. 设置以下任何首选参数:

    自动缩进

    如果打开了自动缩进,在左小括号“(”之后键入的文本将按“制表符大小”设置自动缩进。当您使用左大括号“{”时,此行为也适用。

    制表符大小

    指定新行中将缩进的字符数。

    代码提示

    在“脚本”窗格中启用代码提示。

    延迟

    指定代码提示出现之前的延迟时间(秒)。此选项在 Animate CC 中已弃用。

    字体

    指定用于脚本的字体。

    打开/导入

    指定打开或导入 ActionScript 文件时使用的字符编码。

    保存/导出

    指定保存或导出 ActionScript 文件时使用的字符编码。

    重新加载修改过的文件

    指定脚本文件被修改、移动或删除时将如何操作。 选择“总是”、“从不”或“提示”。

    总是

    不显示警告,自动重新加载文件。

    从不

    不显示警告,文件仍保持当前状态。

    提示

    (默认)显示警告,您可以选择是否重新加载文件。

    使用外部脚本生成应用程序时,此首选项让您能够避免覆盖脚本。或避免使用较早版本的脚本发布应用程序。该警告允许您自动关闭脚本,重新打开较新的、修改后的版本。

    语法着色

    指定在脚本中进行代码着色。

    ActionScript 3.0 设置

    这些按钮打开“ActionScript 设置”对话框,可在其中设置 ActionScript 3.0 的源路径、库路径和外部库路径。

更多此类内容

  • 元件和 ActionScript
  • 时间轴和 ActionScript
  • 声音和 ActionScript
  • 使用 ActionScript 控制外部视频播放
  • 多语言文本和 ActionScript
  • 使用 ActionScript 创建辅助功能
  • 组织应用程序中的 ActionScript
  • 调试 ActionScript3.0
  • 在动作面板中固定脚本
  • 编写和管理脚本
  • 编写和管理脚本
  • 调试 ActionScript3.0
  • 导入和导出脚本
  • 设置代码格式
  • 使用代码提示

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

目前还没有任何评论,快来抢沙发吧!