了解如何使用 Animate CC 中的选取工具 - Adobe Animate 用户指南

返回介绍

了解如何使用 Animate CC 中的选取工具

发布于 2019-06-28 字数 7753 浏览 1129 评论 0

了解如何使用 Animate CC 中的选取工具

在 Animate CC 中,您可以使用指针、部分选取和套索工具来选择对象。选择对象或笔触时,Animate 会用选取框来加亮显示它们。可以只选择对象的笔触,也可以只选择其填充。 可以隐藏选区的加亮显示,这样,在编辑对象时就不会看到加亮显示。

了解如何使用 Animate CC 中的选取工具指针、部分选取和套索工具
了解如何使用 Animate CC 中的选取工具套索工具的功能键

工具 图标 说明
选取工具 (V) 使用此工具可选择一个整个的对象。单击或拖动对象时,其周围会显示一个矩形选框。 
部分选取工具 (A) 使用此工具可改变动画的运动路径。您可以看到路径上对应于每个位置属性关键帧的控制点和贝塞尔手柄。 
套索工具 (L) 使用此工具可为对象创建一个不规则的选区轮廓。 
多边形工具 (L) 使用此工具可定义一个一系列连续直线构成的选区。要选取此工具,可使套索工具保持在选定状态,然后单击多边形工具。 
魔棒工具 (L) 使用此工具可选择具有相同或类似颜色的位图图形区。要选取此工具,可使套索工具保持在选定状态,然后单击魔棒工具。

修改对象

要修改对象,需要先选中它。您可以将若干个单个对象组成一组,然后作为一个对象来处理。 修改线条和形状会改变同一图层中的其他线条和形状。 若要防止选中组或元件并意外修改它,请锁定组或元件。

修改对象的属性

您可以使用属性检查器修改对象的笔触和填充属性。当您选择了某个对象时,“属性”检查器会显示以下内容:

  • 对象的笔触和填充、像素尺寸以及对象的变形点的 x 和 y 坐标。
  • 混合选择(如果选择了多个项目)。 所选项目组的像素尺寸以及 x 和 y 坐标。

用选取工具选择对象

使用选取工具 可以选择全部对象,方法是单击某个对象或拖动对象,便可将其围在一个矩形选框内。要选择实例、组和文本块,必须将它们围起来。 

注意:要选择选取工具,还可以按下 V 键。 要在其他工具处于活动状态时临时切换到选取工具,请按下 Control 键 (Windows) 或 Command 键 (Macintosh)。有关更多信息,请参阅键盘快捷键。 

要禁用 Shift 键选择功能,可以在 Animate 的常规首选参数中取消选择该选项。请参阅设置 Animate 中的首选参数。

选择对象

  • 若要选择笔触、填充、组、实例或文本块,请单击对象。
  • 若要选择连接线,请双击其中一条线。
  • 若要选择填充的形状及其笔触轮廓,请双击填充。
  • 若要选择矩形区域内的对象,请在要选择的一个或多个对象周围拖画出一个选取框。

选取更多对象

  • 若要向选择中添加内容,请按住 Shift 键选取更多对象。
  • 若要选择场景每一层的全部内容,请选择“选择”>“全选”,或者按 Ctrl+A (Windows) 或 Command+A (Macintosh)。 “全选”不会选中被锁定、被隐藏或者不在当前时间轴中的图层上的对象。
  • 若要选择一层中关键帧之间的全部内容,请单击时间轴中的一个帧。

全部取消选择

若要取消选择每一层上的全部内容,请选择“编辑”>“取消全选”,或者按下 Control+Shift+A (Windows) 或 Command+Shift+A (Macintosh)。有关更多信息,请参阅键盘快捷键。 

取消选择单个项

若要取消选择一组选定对象中的任一单个项:

  1. 选择选取工具
  2. 按住 Shift 键 
  3. 单击此单个项

单个项可以是任何笔触、填充或绘制对象。 

锁定/解锁

若要锁定或解锁组或元件,请选择组或元件,然后选择“修改”>“排列”>“锁定”。 选择“修改”>“排列”>“解除全部锁定”可以解锁所有锁定的组和元件。

使用套索工具绘制不规则选区

您可以使用套索工具来创建一个不规则的选区轮廓。从“工具”中选择它或按 L。根据您设置的首选参数,要选取一个对象,可以选择围住绘制对象或是部分围住它。有关更多信息,请参阅本文中的设置用于选择的首选参数部分。  

  1. 在对象区域周围拖动套索工具 。若要选择对象的内圈,可在其周围拖动不规则套索工具。

    了解如何使用 Animate CC 中的选取工具

  2. 在开始位置附近结束拖动,形成一个环,或者让 Animate 自动闭合成环。Animate 将闭合选区轮廓并加亮显示选中的对象。 

    了解如何使用 Animate CC 中的选取工具

使用套索的多边形工具绘制一个直边选区

使用套索工具的多边形模式功能键,可以定义一个一系列连续直线构成的选区。使套索工具保持在选定状态,然后单击多边形工具。 

  1. 在“工具”面板的选项区中选择套索工具的“多边形模式”功能键 了解如何使用 Animate CC 中的选取工具了解如何使用 Animate CC 中的选取工具
  2. 要设置起始点,单击对象。 
  3. 将指针放在第一条线要结束的地方,然后单击该位置。 继续设定其他线段的结束点。

    了解如何使用 Animate CC 中的选取工具

  4. 要闭合选区,双击最后的位置。Animate 将闭合选区轮廓并加亮显示选中的对象。 

    了解如何使用 Animate CC 中的选取工具

绘制一个包含不规则和直边的选区

在使用“套索”工具及其“多边形模式”功能键时,可以在不规则和直边选择模式之间切换。

  1. 取消选择“套索”工具的“多边形模式”功能键。
  2. 要画一条不规则线段,请在舞台上拖动“套索”工具。
  3. 若要设置每条新线段的起点和终点,请按住 Alt 键 (Windows) 或 Option 键 (Macintosh),然后单击该区域。 

    使用此步骤可绘制直边段。 

  4. 要闭合选区,请执行下列操作之一:
    • 松开鼠标按钮。Animate 将闭合选区。 
    • 双击选区线的起始端。

隐藏选区的加亮显示

要查看图稿的最终显示效果,可以在选择和编辑对象时隐藏其加亮显示效果。 

  1. 选择“视图”>“隐藏边缘”。

再次选择“隐藏边缘”选项便可使选区加亮显示。

为所选对象设置自定义边框颜色

您可以自定义舞台上所选对象周围显示的矩形边框的颜色。

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh)。
  2. 单击“常规”类别。
  3. 在“加亮颜色”部分中,为每种类型的对象选择一种颜色,然后单击“确定”。

设置用于选择的首选参数

使用指针、部分选取和套索工具选择对象时,只需单击对象即可。使用指针和部分选取工具选择对象时,只需拖动对象周围的矩形选取框即可。 使用套索工具选择对象时,只需拖动对象周围的自由形状的选取框即可。 选取一个对象后,对象周围会出现一个矩形框。

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh)。
  2. 在“首选参数”对话框的“常规”类别中,请执行下列操作之一:
    • 若想仅选择被包围起来的对象和点,请取消选择“接触即选取”和套索工具。位于选择区域内的点会被选中。
    • 若想选择被部分包围起来的对象或组,请选择“接触即选取”和套索工具。

更多此类内容

  • 颜色、渐变和笔触
  • 组对象
  • 关于元件
  • Animate CC 中的键盘快捷键

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

目前还没有任何评论,快来抢沙发吧!