服务器要求 - CodeIgniter 3.x 用户手册

返回介绍

服务器要求

发布于 2019-10-31 字数 930 浏览 966 评论 0

推荐使用 PHP 5.6 或更新版本。

虽然 CodeIgniter 也可以在 PHP 5.3.7 上运行,但是出于潜在的安全和性能问题,
我们强烈建议你不要使用这么老版本的 PHP,而且老版本的 PHP 也会缺少很多特性。

大多数的 Web 应用程序应该都需要一个数据库。当前 CodeIgniter 支持下列数据库:

  • MySQL (5.1+),驱动有:mysql (已废弃),mysqlipdo
  • Oracle,驱动有:oci8pdo
  • PostgreSQL,驱动有:postgrepdo
  • MS SQL,驱动有:mssqlsqlsrv (2005及以上版本)和 pdo
  • SQLite,驱动有:sqlite (版本2),sqlite3 (版本3)和 pdo
  • CUBRID,驱动有:cubridpdo
  • Interbase/Firebird,驱动有:ibasepdo
  • ODBC:驱动有:odbcpdo (需要知道的是,ODBC 其实只是数据库抽象层)

上一篇:The MIT License (MIT)

下一篇:关于 CodeIgniter

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

支持 Markdown 语法,需要帮助?

目前还没有任何评论,快来抢沙发吧!