FormulaLocal 属性 - Microsoft Excel Visual Basic 2002 参考

返回介绍

FormulaLocal 属性

发布于 2019-08-07 字数 1050 浏览 957 评论 0

返回或设置指定对象的公式,用用户语言中 A1-样式引用。对于 Range 对象,为 Variant 类型;对于 Series 对象,为 String 类型,可读写。


说明


如果指定单元格包含常量,则本属性返回的就是该常量。如果该单元格为空,则本属性将返回一个空字符串。如果该单元格包含公式,本属性将把该公式作为字符串返回,格式与该公式在编辑栏中的显示格式相同(包括等号)。


如果将单元格的值或公式设为日期类型,则 Microsoft Excel 将检查该单元格的格式是否符合某个日期或时间数组格式,如果不符合,将采用默认的短日期数字格式。


如果指定区域是一维或二维区域,则可将公式指定为 Visual Basic 中相同维数的数组。同样,也可在 Visual Basic 数组中使用公式。


对多重单元格区域设置公式,则该区域中所有单元格都用此公式填充。


示例


假定使用的是美国英语版 Microsoft Excel,并往第一张工作表的 A11 单元格中输入了公式“=SUM(A1:A10)”。如果在一台运行德文版 Microsoft Excel 的计算机上打开该工作表,并运行下例,该示例将在消息框中显示公式“=SUMME(A1:A10)”。


MsgBox Worksheets(1).Range(A11).FormulaLocal

上一篇:FormulaLabel 属性

下一篇:FormulaR1C1 属性

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

支持 Markdown 语法,需要帮助?

目前还没有任何评论,快来抢沙发吧!