如何在 Illustrator 中移动、对齐和分布对象 - Illustrator 用户指南

返回介绍

如何在 Illustrator 中移动、对齐和分布对象

发布于 2019-06-18 字数 8504 浏览 1075 评论 0

移动对象

可以通过以下方式移动对象:使用特定工具拖动对象、使用键盘上的箭头键,或在面板或对话框中输入精确数值。

在移动对象时,您可以使用对齐功能来帮助定位对象。例如,您可以使指针对齐参考线和锚点,也可以使对象边界对齐网格线。还可以使用“对齐”面板,根据对象之间的相对位置来对其进行定位。

然后,您便可以使用 Shift 键来限制一个或多个对象的移动,使其沿相对当前 x 轴和 y 轴的精确水平、垂直或对角线方向移动。您还可以用 Shift 键来以 45°角的倍数旋转对象。

如何在 Illustrator 中移动、对齐和分布对象在拖动或拉曳时按住 Shift 键,可将移动限制为邻近的 45°角。

通过粘贴来移动或复制对象

  1. 选择一个或多个对象。
  2. 选择“编辑”>“剪切”来移动所选对象,或选择“编辑”>“复制”来复制所选对象。
  3. 若要将对象粘贴到另一个文件中,请打开该文件。(若要在图层之间粘贴,请参阅在图层之间粘贴对象。)
  4. 执行下列任一命令:

    粘贴”>

    编辑 > 粘贴

    将对象粘贴到现用窗口的中心位置。

    贴在前面”>

    编辑 > 贴在前面

    将对象直接粘贴到所选对象的前面。

    贴在后面”>

    编辑 > 贴在后面

    将对象直接粘贴到所选对象的后面。

    就地粘贴”>

    编辑 > 就地粘贴

    将图稿粘贴到现用画板上,粘贴后的位置与复制该图稿时所在画板上的位置相同。

    在所有画板上粘贴”>

    编辑 > 在所有画板上粘贴

    将图稿粘贴到所有画板上,粘贴后的位置与该图稿在当前画板上的位置相同。

通过拖动来移动对象

  1. 选择一个或多个对象。
  2. 将对象拖动到新位置。

    当所选对象为填充对象时,您可以从对象的任意位置拖动对象。当所选对象为非填充对象时,如果您正在按轮廓查看图稿,或是选中了“仅按路径选择对象”首选项,则必须从对象的路径拖动对象。(请参阅使用拖放操作复制所选对象。)

    注意:若使用“视图”菜单中的“对齐点”命令,则在距锚点或参考线 2 个像素以内的范围内拖动对象时,光标都会靠齐到锚点或参考线。

使用箭头键移动对象

  1. 选择一个或多个对象。
  2. 根据所需的对象移动方向按下相应的箭头键。同时按 Shift 键和箭头键,可使对象按“键盘增量”首选项所设定值的 10 倍移动。

    箭头键每按一次所对应的对象移动距离,由“键盘增量”首选项确定。默认距离为 1 点(1/72 英寸,即 0.3528 毫米)。若要更改“键盘增量”首选项的设置,请选择“编辑”>“首选项”>“常规”(Windows) 或“Illustrator”>“首选项”>“常规”(Mac OS)。

将对象移动特定距离

  1. 选择一个或多个对象。
  2. 选择“对象”>“变换”>“移动”。

    注意:当对象被选中时,您还可以双击“选择”工具、“直接选择”工具或“编组选择”工具来打开“移动”对话框。

  3. 请执行下列任一操作:

    • 若要左移或右移对象,请在“水平”文本框中输入一个负数值(左移)或正数值(右移)。
    • 若要上移或下移对象,请在“垂直”文本框中输入一个负数值(上移)或正数值(下移)。
    • 若要按照对象与 x 轴的夹角移动对象,请在“距离”文本框或“角度”文本框中输入一个正角度(逆时针移动)或负角度(顺时针移动)。您还可以输入介于 180°与 360°之间的角度值;这些值会被转换为与之对应的负角度值(例如,270°会被转换为 -90°)。
  4. 如果对象包含图案填充,请选择“图案”以移动图案。如果您只想移动图案,而不想移动对象的话,请取消选择“对象”。
  5. 单击“确定”,或是单击“复制”以移动对象的副本。

    如何在 Illustrator 中移动、对齐和分布对象相对 x 轴的方向

使用 x 和 y 坐标移动对象

  1. 选择一个或多个对象。
  2. 在“变换”面板或“控制”面板的 X 和/或 Y 文本框中输入新值。

    若要更改参考点的设置,请在输入值之前单击参考点定位器 如何在 Illustrator 中移动、对齐和分布对象 中的一个白方块。

一次移动多个对象

  1. 选择一个或多个对象。
  2. 选择“对象”>“变换”>“分别变换”。
  3. 在对话框的“移动”部分设置希望所选对象移动的距离。
  4. 执行下列操作之一:

    • 若要让对象按指定值移动,请单击“确定”。
    • 若要随机移动对象而不超出指定值,请选择“随机”选项。例如,如果您画了一面砖墙,想让砖之间出现轻微的相互偏移,而不是完全对齐,则可以选择使用“随机”选项, 然后单击“确定”。

相对其他对象位置粘贴对象

  1. 选择要粘贴的对象。
  2. 选择“编辑”>“复制”或“编辑”>“剪切”。
  3. 选择要在前面或后面粘贴此对象的目标对象。
  4. 选择“编辑”>“贴在前面”,或“编辑”>“贴在后面”。

    如果粘贴多个对象,粘贴的所有对象都会出现在所选图稿的前面或后面。但其中各个粘贴对象之间的相对绘画顺序仍保持不变。

在图层之间粘贴对象

“粘贴时记住图层”选项决定图稿在图层结构中的粘贴位置。默认情况下,“粘贴时记住图层”选项处于关闭状态,并会将图稿粘贴到“图层”面板中处于现用状态的图层中。当“粘贴时记住图层”选项打开时,会将图稿粘贴到复制图稿的图层中,而不管该图层在“图层”面板中是否处于现用状态。

可以通过从“图层”面板菜单中选择“粘贴时记住图层”来设置此选项。选项打开时,会显示一个选中标记。

注意:如果您是在文档间粘贴图稿,并希望将图稿自动置入到与其原所在图层名称相同的图层中,请打开“粘贴时记住图层”选项。如果目标文档中没有与原图层名称相同的图层,Illustrator 便会创建一个新的图层。

就地粘贴以及在所有画板上粘贴

“就地粘贴”命令会将图稿粘贴到现用画板。若要使用此命令,请单击“编辑”>“就地粘贴”。键盘快捷键为 Ctrl+Shift+V (Windows) 或 Cmd+Shift+V (Mac)。

“在所有画板上粘贴”命令会将所选的图稿粘贴到所有画板上。使用“在所有画板上粘贴”命令之前,请确保您复制的对象所在的画板是现用画板。

要使用“在所有画板上粘贴”命令,请在剪切或复制图稿时单击“编辑”>“在所有画板上粘贴”。

如果是复制图稿后选择“在所有画板上粘贴”,则在该图稿所在的画板上,会将其再粘贴一次。(建议)如果不需要在使用“在所有画板上粘贴”选项之前修改原始对象,请使用“剪切”功能,然后再粘贴对象。

注意:使用“就地粘贴”和“在所有画板上粘贴”命令时,所复制的对象粘贴到画板上的位置,就是在复制该对象时它在现用画板上所处的位置。

对齐和分布对象

使用“对齐”面板(“窗口”>“对齐”)和“控制”面板中的对齐选项可沿指定的轴对齐或分布所选对象。可以使用对象边缘或锚点作为参考点,并且可以对齐所选对象、画板或关键对象。关键对象指的是选择的多个对象中的某个特定对象。

当选定对象时,“控制”面板中的对齐选项可见。如果未显示这些选项,请从“控制”面板菜单中选择“对齐”。

注意:默认情况下,Illustrator 会根据对象路径计算对象的对齐和分布情况。不过,当处理具有不同描边粗细的对象时,您可以改为使用描边边缘来计算对象的对齐和分布情况。若要执行此操作,请从“对齐”面板菜单中选择“使用预览边界”。

相对于所有选定对象的定界框对齐或分布

  1. 选择要对齐或分布的对象。
  2. 在“对齐”面板或“控制”面板中,选择“对齐所选对象”如何在 Illustrator 中移动、对齐和分布对象,然后单击与所需的对齐或分布类型相对应的按钮。

相对于一个锚点对齐或分布

  1. 单击直接选择工具,按住 Shift 并选择要对齐或分布的锚点。所选择的最后一个锚点会作为关键锚点。

    会自动选中“对齐”面板和“控制”面板中的“对齐关键锚点” 如何在 Illustrator 中移动、对齐和分布对象 选项。

  2. 在“对齐”面板或“控制”面板中,单击与所需的对齐或分布类型对应的按钮。

相对于关键对象对齐或分布

  1. 选择要对齐或分布的对象。
  2. 再次单击要用作关键对象的对象(这一次无需在单击时按住 Shift)。

    关键对象周围出现一个蓝色轮廓,并会在“控制”面板和“对齐”面板中自动选中“对齐关键对象” 如何在 Illustrator 中移动、对齐和分布对象

  3. 在“对齐”面板或“控制”面板中,单击与所需的对齐或分布类型对应的按钮。

    注意:要停止相对于某个对象进行对齐和分布,请再次单击该对象以删除蓝色轮廓,或者从“对齐”面板菜单中选择“取消关键对象”。

相对于画板对齐或分布

  1. 选择要对齐或分布的对象。
  2. 使用选择工具,按住 Shift 键单击要使用的画板以将其激活。现用画板的轮廓比其他画板要深。
  3. 在“对齐”面板或“控制”面板中,选择“对齐画板”如何在 Illustrator 中移动、对齐和分布对象,然后单击与所需的对齐或分布类型相对应的按钮。

按照特定间距量分布对象

您可用对象路径之间的精确距离来分布对象。

  1. 选择要分布的对象。
  2. 使用选择工具 如何在 Illustrator 中移动、对齐和分布对象 单击要在其周围分布其他对象的对象的路径。您单击的对象将在原位置保留不动。
  3. 在“对齐”面板中的“分布间距”文本框中输入要在对象之间显示的间距量。

    如果未显示“分布间距”选项,请从面板菜单中选择“显示选项”。

  4. 单击“垂直分布间距”按钮或“水平分布间距”按钮。

更多此类内容

  • 使用网格
  • 旋转对象
  • 变换面板概述
  • 绘制用于 Web 工作流程的像素对齐路径
  • 图层面板概述
  • 工作区基础知识
  • 使用多个画板

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

目前还没有任何评论,快来抢沙发吧!