6.5. 不同MySQL版本之间的复制兼容性 - MySQL 中文手册

返回介绍

6.5. 不同MySQL版本之间的复制兼容性

发布于 2019-06-13 字数 907 浏览 1032 评论 0

MySQL 5.1中使用的二进制日志格式与以前的版本中所使用的大大不同,特别是在字符集处理、LOAD DATA INFILE以及时区方面。

注释:你不能从使用新二进制日志格式的主服务器向使用旧二进制日志格式的从服务器复制(例如,从MySQL 5.0到MySQL 4.1)。。这样操作在复制设置升级服务器时后果严重,参见6.6节,“升级复制设置”。

我们推荐使用最近的MySQL版本,因为复制功能在不断地改进中。我们还推荐主服务器和从服务器使用相同的版本。我们建议升级主服务器和从服务器,运行alpha或beta版本到新的(产品)版本。在许多情况下,从新的主服务器向旧的从服务器复制将会失败。一般原则,运行MySQL 5.1.x的从服务器可以与旧的主服务器(可以运行MySQL 3.23、4.0或者4.1)一起使用,但不能反过来。

前面的信息适合协议级复制兼容性。然而,还会有一个约束条件,例如SQL级兼容性问题。例如, 5.1版本的主服务器不能复制到5.0版本的从服务器,如果复制语句使用5.1版本的SQL特性而不是5.0版本。这些问题和其它问题均在6.7节,“复制特性和已知问题”中讨论。

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

目前还没有任何评论,快来抢沙发吧!