Photoshop 中的测量功能 - Photoshop 用户指南

返回介绍

Photoshop 中的测量功能

发布于 2019-06-14 字数 11730 浏览 806 评论 0

注意:在 Photoshop CS6 中,3D 功能是 Photoshop Extended 的一部分。Photoshop Extended 中的所有功能是 Photoshop 的一部分。Photoshop 不提供单独的 Extended 版本。

关于测量

通过使用 Photoshop 的测量功能,可以测量用标尺工具或选择工具定义的任何区域,包括用套索工具、快速选择工具或魔棒工具选定的不规则区域。也可以计算高度、宽度、面积和周长,或跟踪一个或多个图像的测量。测量数据会记录在“测量记录”面板中。可以自定“测量记录”列,将列内的数据排序,并将记录中的数据导出到以制表符分隔的 Unicode 文本文件中。

测量比例

设置测量比例将在图像中设置一个与比例单位(如英寸、毫米或微米)数相等的指定像素数。在创建比例之后,您就可以用选定的比例单位测量区域并接收计算和记录结果。尽管在文档中一次只能使用一个比例,但可以创建多个测量比例预设。

比例标记

可以将比例标记放置在图像上以显示测量比例。比例标记可以带有或不带有显示测量比例单位的题注。

设置测量比例

使用标尺工具设置文档的测量比例。可以为经常使用的测量比例创建测量比例预设。预设将会添加到“图像”>“分析”>“设置测量比例”子菜单。文档的当前测量比例在子菜单中将被选中,并出现在“信息”面板中。

注意:会自动为 DICOM 文件设置测量比例。请参阅关于 DICOM 文件。

选择“图像”>“分析”>“设置测量比例”>“默认值”可返回默认测量比例,即 1 像素 = 1 像素。

设置测量比例

  1. 打开一个文档。
  2. 选择“图像”>“分析”>“设置测量比例”>“自定”。会自动选定“标尺”工具 。拖动该工具以测量图像中的像素距离或在“像素长度”文本框中输入一个值。当您关闭“测量比例”对话框时,将恢复当前工具设置。
  3. 输入要设置为与像素长度相等的逻辑长度和逻辑单位。

    例如,如果像素长度为 50,并且要设置的比例为 50 像素/微米,则应输入 1 作为逻辑长度,并使用微米作为逻辑单位。

  4. 在“测量比例”对话框中单击“确定”以设置文档上的测量比例。
  5. 选择“文件”>“存储”以将当前测量比例设置与文档一起存储。

    要在“信息”面板中显示比例,请从面板菜单 Photoshop 中的测量功能 中选取“面板选项”,并选择“状态信息”区域中的“测量比例”。

    注意:要在文档窗口的底部显示测量比例,请从文档窗口菜单中选择“显示”>“测量比例”。

创建测量比例预设

  1. 打开一个文档。
  2. 选择“图像”>“分析”>“设置测量比例”>“自定”。
  3. 创建测量比例。
  4. 单击“存储预设”并命名预设。
  5. 单击“确定”。您创建的预设将会添加到“图像”>“分析”>“设置测量比例”子菜单中。

删除测量比例预设

  1. 选择“图像”>“分析”>“设置测量比例”>“自定”。
  2. 选择要删除的预设。
  3. 单击“删除预设”,然后单击“确定”。

使用比例标记

测量比例标记将显示文档中使用的测量比例。请在创建比例标记之前设置文档的测量比例。可以用逻辑单位设置标记长度,包含指明长度的文本题注,并将标记和题注颜色设置为黑色或白色。

创建比例标记

  1. 选择“图像”>“分析”>“置入比例标记”。
  2. 在“测量比例标记”对话框中,设置下列选项:

    长度

    输入一个值以设置比例标记的长度。标记的长度(以像素为单位)将取决于当前为文档选定的测量比例。

    字体

    选取显示文本的字体。

    字体大小

    选取显示文本的字体大小。

    显示文本

    选择此选项以显示比例标记的逻辑长度和单位。

    文本位置

    在比例标记的上方或下方显示题注。

    颜色

    将比例标记和题注颜色设置为黑色或白色。

  3. 单击“确定”。

比例标记将被放置到图像的左下角。该标记会向文档添加一个图层组,其中包含文本图层(如果已选定“显示文本”选项)和图形图层。可以使用移动工具移动比例标记,或使用文本工具编辑题注或更改文本的大小、字体或颜色。

添加或替换比例标记

可以在文档中放置多个比例标记或替换现有标记。

注意:其它比例标记会放置到图像上的同一位置并可能会彼此遮盖,具体取决于它们的长度。要查看下方的标记,请关闭比例标记图层组。

  1. 选择“图像”>“分析”>“置入比例标记”。
  2. 单击“移去”或“保留”。
  3. 输入新标记的设置,然后单击“确定”。

删除比例标记

  1. 在“图层”面板中,选择要删除的比例标记对应的“测量比例标记”图层组。
  2. 右键单击该图层组,并从上下文菜单中选择“删除组”,或单击“删除图层”按钮。
  3. 单击“组和内容”。

执行测量

可以使用 Photoshop 的选择工具、标尺工具或计数工具来进行测量。选择与要在“测量记录”中记录的数据类型匹配的测量工具。

  • 创建一个选区以测量各种值,如高度、宽度、周长、面积和像素灰度值。一次可以测量一个或多个选区。
  • 用标尺工具绘制线条以测量直线距离和角度。
  • 使用计数工具计算图像上的项目数,然后记录此项目数。请参阅对图像中的对象计数。

    每次测量都会测量一个或多个数据点。选择的数据点将决定在测量记录中记录的信息。数据点对应于测量时使用的工具的类型。面积、周长、高度和宽度是测量选区时可用的数据点。长度和角度是标尺工具测量可用的数据点。可以为特殊类型的测量创建和存储数据点组以加快工作流程。

  1. 打开现有文档。
  2. 选择“图像”>“分析”>“设置测量比例”并为文档选择一个测量比例预设(请参阅设置测量比例),或选择“自定”并设置一个自定测量比例。

    使用在记录测量时有效的比例单位在测量记录中计算和记录测量。如果不存在任何测量比例,默认比例为:1 像素 = 1 像素。

  3. (可选)选择“图像”>“分析”>“选择数据点”并执行下列操作之一:

    • 选择“自定”以选择要测量的数据点。
    • 从子菜单中选择现有数据点预设。

    在“选择数据点”对话框中,数据点将根据可以测量它们的测量工具进行分组。“通用”数据点适用于所有工具。这些数据点会向测量记录添加有用信息,如要测量的文件的名称、测量比例和测量的日期/时间。

    默认情况下,将选择所有数据点。可以为特定测量类型选择数据点子集,并将此组合存储为数据点预设。

    注意:当使用特定工具进行测量时,只有与该工具关联的数据点才会显示在记录中,即使已选择其它数据点也是如此。例如,如果使用“标尺”工具进行测量,则只有“标尺”工具数据点才会和已选择的任何“通用”数据点一起显示在“测量记录”中。

  4. 选择某个图像功能和测量工具以匹配选定的数据点。执行下列操作之一:
    • 在图像上创建一个或多个选区。
    • 选择“图像”>“分析”>“标尺工具”,或单击工具箱中的标尺工具,然后使用此工具测量图像区域的长度。
    • 选择“图像”>“分析”>“计数工具”,或单击工具箱中的计数工具,然后计算图像中的项目数。
  5. 选取“窗口”>“测量记录”以打开“测量记录”面板。
  6. 选择“图像”>“分析”>“记录测量”,或单击“测量记录”面板中的“记录测量”。

    注意:如果当前选定的数据点与当前测量工具不对应,则会要求您选择对应于该工具的数据点。

    测量记录包含多个列,这些列与在“选择数据点”对话框中选定的每个数据点相对应。每一次测量都会在测量记录中输入一个新的数据行。

    如果测量图像上的多个选定区域,则会在记录中创建一行数据以包含所有选定区域的摘要或累积数据,并在该行后面为每个选区创建一行数据。每个选区在记录的“标签”列中作为单独的“特征”列出,并分配有一个唯一的编号。

    可以为同一文档或多个文档中的各种不同的选区重复第 2 步到第 6 步。测量记录中的“文档”列反映了测量数据的源。

测量数据点

角度

标尺工具的方向角度 (±0-180)。

面积

用方形像素或根据当前测量比例校准的单位(如平方毫米)表示的选区的面积。

圆度

4pi(面积/周长2)。若值为 1.0,则表示一个完全的圆形。当值接近 0.0 时,表示一个逐渐拉长的多边形。值对于非常小的选区可能无效。

计数

根据使用的测量工具发生变化。选择工具:图像上不相邻的选区的数目。计数工具:图像上已计数项目的数目。标尺工具:可见的标尺线的数目(1 或 2)。

日期和时间

应用表示测量发生时间的日期/时间戳。

文档

标识测量的文档(文件)。

灰度值

这是对亮度的测量,范围从 0 到 255(对于 8 位图像)、0 到 32,768(对于 16 位图像)或 0.0 到 10(对于 32 位图像)。对于所有与灰度值相关的测量,将使用默认灰度配置文件,在内部将图像转换为灰度(相当于选取“图像”>“模式”>“灰度”)。然后,为每个特征和摘要执行请求的计算(平均值、中间值、最小值、最大值)。

高度

选区的高度 (max y – min y),其单位取决于当前的测量比例。

直方图

为图像中的每个通道(RGB 图像有三个通道,CMYK 图像有四个通道,等等)生成直方图数据,并记录 0 到 255(将 16 位或 32 位值转换为 8 位)之间的每个值所表示的像素的数目。从“测量记录”中导出数据时,数字直方图数据将导出到一个 CSV(以逗号分隔值)文件中。该文件会放在它自己的文件夹中,其位置与以制表符分隔的测量记录文本文件的导出位置相同。将为这些直方图文件分配一个唯一编号,编号从 0 开始并且每次增加 1。对于一次测量的多个选区,将为整个选定区域生成一个直方图文件,并为每个选区生成附加的直方图文件。

累计密度

选区中的像素值的总和。此值等于面积(以像素为单位)与平均灰度值的乘积。

标签

标识每个测量并自动将每个测量编号为测量 1、测量 2,等等。对于同时测量的多个选区,将为每个选区分配一个附加的“特征”标签和编号。

长度

标尺工具在图像上定义的直线距离,其单位取决于当前的测量比例。

周长

选区的周长。对于一次测量的多个选区,将为所有选区的总周长生成一个测量,并为每个选区生成附加测量。

比例

源文档的测量比例(例如,100 像素 = 3 英里)。

比例单位

测量比例的逻辑单位。

比例因子

分配给比例单位的像素数。

测量的源:标尺工具、计数工具或选择工具。

宽度

选区的宽度 (max x – min x),其单位取决于当前的测量比例。

创建数据点预设

  1. 选择“图像”>“分析”>“选择数据点”>“自定”。
  2. 选择要在预设中包含的数据点。
  3. 单击“存储预设”并命名预设。
  4. 单击“确定”。将存储该预设,并且现在就可以从“分析”>“选择数据点”子菜单中使用该预设。

编辑数据点预设

  1. 选择“图像”>“分析”>“选择数据点”>“自定”。
  2. 选择要从“预设”菜单中编辑的预设。
  3. 选择或取消选择数据点。预设名称将更改为“自定”。
  4. 单击“存储预设”。输入原来的预设名称以替换现有预设,或输入新名称以创建新预设。

删除数据点预设

  1. 选择“图像”>“分析”>“选择数据点”>“自定”。
  2. 选择要从“预设”菜单中删除的预设。
  3. 单击“删除预设”,然后单击“是”以确认删除。
  4. 单击“确定”。

使用测量记录

当测量对象时,“测量记录”面板会记录测量数据。此记录中的每一行表示一个测量组;列表示测量组中的数据点。

当测量对象时,测量记录中就会出现新行。可以为记录中的列重新排序,为列中的数据排序,删除行或列,或者将记录中的数据导出到逗号分隔的文本文件中。

显示测量记录

  1. 执行下列操作之一:
    • 选择“图像”>“分析”>“记录测量”。
    • 选择“窗口”>“测量记录”。

选择记录中的行

  1. 执行下列操作之一:
    • 在记录中单击某个行以将其选定。
    • 要选择多个连续行,请单击第一行并拖过其他行,或单击第一行,然后按住 Shift 键并单击最后一行。
    • 要选择多个不相邻的行,请单击第一行,然后按住 Ctrl 键 (Windows) 或 Command 键 (Mac) 并单击其它行。
    • 要选择所有行,请单击“全选”。
    • 要取消选择所有行,请单击“不选”。

选择记录中的列

  1. 执行下列操作之一:
    • 单击某个列标题。
    • 要选择多个相邻的列,请单击一个列标题并拖过其它列,或单击第一个列标题,然后按住 Shift 键并单击最后一个列标题。
    • 要选择多个不相邻的列,请单击第一个列标题,然后按住 Ctrl 键 (Windows) 或 Command 键 (Mac) 并单击其它列标题。

对记录中的列进行重新排序、调整大小或数据排序

  1. 执行下列操作之一:
    • 在记录中拖动选定的列以对这些列重新排序。列位置用双黑线指示。
    • 要调整列的大小,请单击列标题,然后拖动分隔符。
    • 要对列中的数据排序,请单击列标题以更改排序顺序,或右键单击标题并选取“升序排序”或“降序排序”。(无法手动对行进行重新排序。)

删除记录中的行或列

  1. 在记录中选择一个或多个行或列。
  2. 执行下列操作之一:
    • 从“测量记录”选项菜单中选择“删除所选测量”。
    • 单击面板顶部的“删除”图标。
    • 在行或列标题中右键单击,然后从弹出菜单中选择“删除”。

导出测量记录数据

可以将测量记录中的数据导出到逗号分隔的文本文件中。可以在电子表格应用程序中打开该文本文件,并利用这些测量数据执行统计或分析计算。

  1. 在记录中选择一个或多个数据行。
  2. 执行下列操作之一:
    • 从“测量记录”选项菜单中选择“导出所选测量”。
    • 单击面板顶部的“导出”图标。
    • 在行中右键单击,然后从弹出菜单中选择“导出”。
  3. 输入文件名和位置,然后单击“存储”。

    将测量导出到逗号分隔的 UTF-8 文本文件中。

更多此类内容

  • 使用智能参考线

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

目前还没有任何评论,快来抢沙发吧!