PHP-安装wamp环境,为什么apache总是打不开

PHP-安装wamp环境,为什么apache总是打不开

夜无邪 发布于 2017-01-13 字数 1462 浏览 1064 回复 6

安装集成的wamp环境,apache总是打不开,80端口没有被占用,看一下错误日志
[Tue Feb 13 11:51:56 2007] [notice] Apache/2.2.4 (Win32) PHP/5.2.0 configured -- resuming normal operations
[Tue Feb 13 11:51:56 2007] [notice] Server built: Jan 9 2007 23:17:20
[Tue Feb 13 11:51:56 2007] [notice] Parent: Created child process 3808
[Tue Feb 13 11:51:58 2007] [notice] Child 3808: Child process is running
[Tue Feb 13 11:51:58 2007] [notice] Child 3808: Acquired the start mutex.
[Tue Feb 13 11:51:58 2007] [notice] Child 3808: Starting 250 worker threads.
[Tue Feb 13 11:51:58 2007] [notice] Child 3808: Starting thread to listen on port 80.
[Tue Feb 13 11:52:01 2007] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Feb 13 11:52:01 2007] [notice] Child 3808: Exit event signaled. Child process is ending.
[Tue Feb 13 11:52:02 2007] [notice] Child 3808: Released the start mutex
[Tue Feb 13 11:52:03 2007] [notice] Child 3808: Waiting for 250 worker threads to exit.
[Tue Feb 13 11:52:03 2007] [notice] Child 3808: All worker threads have exited.
[Tue Feb 13 11:52:03 2007] [notice] Child 3808: Child process is exiting
[Tue Feb 13 11:52:03 2007] [notice] Parent: Child process exited successfully.
[Tue Feb 13 11:52:51 2007] [notice] Apache/2.2.4 (Win32) PHP/5.2.0 configured -- resuming normal operations

前几行有这个,也不知道是不是错,各位大侠帮助下哈

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(6

归属感 2017-08-18 6 楼

[Tue Feb 13 11:52:01 2007] [notice] Parent: Received shutdown signal -- Shutting down the server.
似乎是你的apache起来了,又被关了,你把apache换个端口看看,netstat —ntpl检测下80端口是不是被占用了。

想挽留 2017-08-13 5 楼

ExpiresActive On
header append cache-control: "no-cache"
header append pragma: "no-cache"
header append expires: "-1"

我在httpd.conf配置文件中加入上面的配置信息,也会出现如同楼主一样的错误

晚风撩人 2017-07-22 4 楼

看Apache的这个提示应该是有程序占用着80端口,导致Apache2无法启动,你检查一下80端口是被什么程序占用了,例如SKype等软件也会占用80端口,你试试把所有软件全部退出,然后再启动Apache试试

晚风撩人 2017-06-21 3 楼

先检查一下你的httpd.conf,看看里面各处配置的文件路径是否正确,再用netstat -ano命令看看http的80端口、ssl的443端口是否被占用,找到端口对应的pid,再使用任务管理器通过pid找到对应的程序,禁止掉其自动启动,然后再试试启动的环境

泛泛之交 2017-05-30 2 楼

修改一下你本机设置:

网上邻居->本地连接->属性->internet协议(TCP/IP)->属性->高级->wins标签->去掉启用LMhosts查询前的勾.

如果还不行,你本机是否装防火墙了呀,先关掉防火墙再试试!

甜柠檬 2017-04-28 1 楼

是不是你apache版本问题,你检查一下。
看看你的apache是什么版本的,如果是apache2.2.X版本
找到你的httpd.conf把
LoadModule php5_module e:/php/php5apache2.dll
替换成
LoadModule php5_module e:/php/php5apache2_2.dll
然后重启Apache再试试。