从开源中国上克隆代码,遇到Protocol https not supported or disabled in libcurl,何解

从开源中国上克隆代码,遇到Protocol https not supported or disabled in libcurl,何解

清晨说晚安 发布于 2021-11-24 字数 333 浏览 858 回复 9

我电脑是Windows7旗舰版,安装完了git-gui1.8.3版本之后,配置好了用户名,邮箱,ssh key,可是克隆代码的时候居然提示

fatal: unable to access 'https://git.oschina.net/xxx.git/': Protocol https not supported or disabled in libcurl

难道我还需要做什么配置吗,我在另外一台电脑都没有遇到这个问题呢

如果你对这篇文章有疑问,欢迎到本站 社区 发帖提问或使用手Q扫描下方二维码加群参与讨论,获取更多帮助。

扫码加入群聊

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(9

悲喜皆因你 2021-12-01 9 楼

libcurl.dll加个后缀.old就行了,感谢这个方法。

但是问题的根本原因是什么呢?

等风来 2021-12-01 8 楼

的确是楼上所说的原因  感谢

落墨 2021-11-30 7 楼

这个方法很奏效,非常感谢

一人独醉 2021-11-30 6 楼

我的也是,删掉libcurl.dll就可以了,不知是何原因?我的Git在Win下是覆盖安装的

无边思念无边月 2021-11-30 5 楼

引用来自“shichaopeng”的评论

libcurl的版本不重复或有错误发生,

草莓味的萝莉 2021-11-29 4 楼

正解

岁吢 2021-11-28 3 楼

libcurl的版本不重复或有错误发生,

瀞厅☆埖开 2021-11-28 2 楼

茅塞顿开

绝情姑娘 2021-11-25 1 楼

配置了ssh key为什么不用git@git.oschina.net:username/projectname.git这种形式的地址呢?你的地址是https方式,是不是输入错了呢,检查一下