怎么在MVN里找特定包

怎么在MVN里找特定包

拍不死你 发布于 2021-11-25 字数 466 浏览 690 回复 3

以前配MVN 都是百度找模板,现在遇到配置postgresql数据的JDBC包,比较少见。就是一下标签。前面的groupid和artifactId 都找到了。我现在要9.4包,不知道怎么填。有没有比较智能的方式?<dependency>

<groupId>org.postgresql</groupId>

<artifactId>postgresql</artifactId>

<version>9.4</version>

</dependency>

如果你对这篇文章有疑问,欢迎到本站 社区 发帖提问或使用手Q扫描下方二维码加群参与讨论,获取更多帮助。

扫码加入群聊

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(3

完美解决问题~

落墨 2021-11-30 2 楼

如果用的是eclipse, 打开pom.xml之后, 右键菜单->Maven->Add Dependency, 输入groupId可以自动列出所有可用的版本, 这个是本地索引的可用的版本, 并不是中央仓库中最新的.

心舞飞扬 2021-11-28 1 楼

http://maven.oschina.net/

http://search.maven.org/

去中央仓库搜呗, 或则oschina提供的Nexus私服上也可以

http://maven.oschina.net/index.html#nexus-search;gav~org.postgresql~~~~

如果你想确认正确的版本, 最好是去用到的库的官方站点上确认相应的版本